Wie das Member Sherif Hashim vom Dev Team über Twitter mitteilte, hat Apple das Exploit welches momentan für einen Unlock mit ultrasn0w 0.9.3 verwendet wird geschlossen, und hat auf die Baseband Version 05.14.01 aktualisiert. Daher empfiehlt sich ein Update des iOS höher als die Version 4.0.1 nur dann, man man sein Gerät nicht selbst entsperren muss um eine Mobilfunkkarte eines anderen Anbieters zu nutzen. Man sollte, sofern man einen Jailbreak und/oder Unlock braucht, eh erst auf eine Reaktion des Dev-Teams warten. Der Jailbreak/Unlock für das iPhone 4 lässt ja auch noch auf sich warten.